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Installing Doc-To-Help 

 

Before beginning your Doc-To-Help installation: 

 

1. Verify the System Requirements. (See System Requirements on page 2.) 

2. Close Microsoft® Word.  

3. Close Microsoft® Outlook if Microsoft Word is your default email editor. 

4. Turn off your anti-virus software. (You can turn it back on after installation is complete, although you may need 

to modify it later. See Using Anti-virus Software with Doc-To-Help on page 5.) 

System Administrators: If you are a system administrator  installing Doc-To-Help for another user, please note that 

Doc-To-Help uses Templates and Themes  that are installed by default to specific folders. If the user does not have 

permissions to use or update these folders, they will have issues using Doc-To-Help. In order to ensure that the user will 

have no issues, please test the installation after it is performed. See Step 4 in the Installation Instructions on page 3 for 

details. For information about where Doc-To-Help stores Templates and Themes during installation, see File Locations 

on page 11.   

 

Please note if you are upgrading or moving your Doc-To-Help installation: 

 If you are upgrading Doc-To-Help, and have customized Doc-To-Help Templates, Themes, and Style Sheets, 

Doc-To-Help automatically backs them up for you during installation. Please see File Locations on page 11 for 

details. Also, after upgrading, when you open an existing project, Doc-To-Help will notify you that the project 

will be upgraded to the new version. Click OK to accept. Use the Rebuild Target button (on the Home tab of 

Doc-To-Help) the first time you build the project in the new version. 

 If you are moving your copy of Doc-To-Help from the computer it is currently installed on to another computer, 

you must deactivate the license and uninstall it before beginning the new installation. See Deactivating Doc-To-

Help on page 5 for instructions.   
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System Requirements 
Before beginning installation, verify that your PC meets the following requirements. Please note that Microsoft® Word, 

FrontPage®, and Adobe® Dreamweaver® are required only if you plan to use them as editors.       

    

Computer/Processor PC with Intel® Pentium® II 500 MHz or greater processor 

Memory 512 MB of RAM Minimum 

Hard Disk Space 200 MB of hard disk space for the Doc-To-Help application and related 

files 

Operating System Microsoft® Windows XP (with Service Pack 2), Microsoft® Vista, or 

Microsoft® Windows 7 

Microsoft Word Microsoft® Word 2000 (version 9.0) or greater, Word 2003, Word 2007, 

or Word 2010 

Microsoft FrontPage Microsoft® FrontPage® 2003 SP2 

Adobe Dreamweaver Adobe® Dreamweaver® MX2004, 8.0, 9.0, CS3, CS4, or CS5 

.NET Framework Microsoft® .NET framework version 2.0 or later. 

The Doc-To-Help installation will check for the presence of the Microsoft 

.NET 2.0 Framework. If it is not found, you can visit Microsoft’s web site 

for a free download: 

http://www.microsoft.com/downloads/details.aspx?FamilyID=0856EACB-

4362-4B0D-8EDD-AAB15C5E04F5&displaylang=en. (If you purchased 

Doc-To-Help on CD, the Framework is available there also.) 

Microsoft Data Access 

Components (MDAC) 

MDAC version 2.6 or later 

(normally installed as part of your operating system) 

Browser Microsoft® Internet Explorer® 8 or greater  

(for use by the Theme Designer) 

 

If using Doc-To-Help's SharePoint integration, Doc-To-Help collaboration features are compatible with Microsoft® 

SharePoint® 2007 and 2010, as well as Office 365 (SharePoint Online). SharePoint 2010 is required when publishing 

Doc-To-Help Targets to a SharePoint Wiki Library. SharePoint 2010 is recommended when working with Translation 

Libraries. Translation Libraries cannot be managed in Windows SharePoint Services 3.0, because WSS 3.0 does not 

support them. 

 

Prerequisites for Office 365 (SharePoint Online): 

 Microsoft® .NET Framework 3.5 

 Windows Identity Foundation http://www.microsoft.com/download/en/details.aspx?id=17331   

 

Supported operating systems for Office 365:  

Windows 7, Windows Server 2008 R2, Windows Server 2008 Service Pack 2, Windows Vista Service Pack 2, Windows 

Server 2003 Service Pack 2. 

If storing your Team Project in a Team Foundation Server repository, Doc-To-Help supports Microsoft Team 

Foundation Server 2008 and 2010. 

http://www.microsoft.com/downloads/details.aspx?FamilyID=0856EACB-4362-4B0D-8EDD-AAB15C5E04F5&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=0856EACB-4362-4B0D-8EDD-AAB15C5E04F5&displaylang=en
http://www.microsoft.com/download/en/details.aspx?id=17331
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Installation Instructions 
Your machine setup may require that you be logged in as an Administrator to install new software. If this is the case and 

you do not have Administrator privileges, consult your system administrator.  

1. Go to http://www.doctohelp.com/download to download the latest version of Doc-To-Help. Save the .msi file to 

your computer. 

2. Double-click the .msi file to launch the installer. 

3. Follow the wizard to complete the installation.  

[If you have an installation CD, insert it into your CD-ROM drive. Select and run the Setup.exe file from your 

CD drive. Choose the Install option. ] 

4. Test the installation by creating a new project in Doc-To-Help. This test should be performed when logged in as 

the Doc-To-Help user. (If an administrator has performed the install, they should log out and log back in as the 

Doc-To-Help end user before performing the test.) 

 Choose the File tab > New Project 

  

 Choose the defaults in the New Project Wizard, and on the Select Source Content Type screen, choose 

Microsoft Word Document. (If you do not have Word installed, choose XHTML or HTML document.) 

 Do not modify the default content generated by Doc-To-Help. 

 Close the open editor (Microsoft Word, Doc-To-Help’s built-in XHTML Editor, Microsoft FrontPage or 

Adobe Dreamweaver). 

 After the project is created, click the Build Target button (on the Home tab of Doc-To-Help) and build the 

project. If it builds, the install was successful. 

 

After a successful installation test, you should close Doc-To-Help, then reopen it to activate the license. 

If you have an Internet connection, enter your serial number when requested and Doc-To-Help will communicate with 

the activation servers and activate your license for you. (You must have administrator rights to activate Doc-To-Help.) If 

you do not have an Internet connection Doc-To-Help will provide you with alternatives to automatic activation. For more 

information see: Activating Doc-To-Help.  

 
Silent Installation 
Doc-To-Help supports all standard installer command line options for Windows, see http://msdn.microsoft.com/en-

us/library/windows/desktop/aa367988(v=vs.85).aspx  

 

To install DocToHelp silently into a specific folder use the following command: 

msiexec /qn /i "pathtomsifile" INSTALLLOCATION="pathtofolder" 

http://www.doctohelp.com/download
http://msdn.microsoft.com/en-us/library/windows/desktop/aa367988(v=vs.85).aspx
http://msdn.microsoft.com/en-us/library/windows/desktop/aa367988(v=vs.85).aspx
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Installing the DynamicHelp Control (optional) 

After you have installed Doc-To-Help, you will be asked if you would like to install the C1DynamicHelp Control. This 

control has been included with Doc-To-Help at no cost and can be used by software developers  to create a dynamic 

Help pane in any application developed in Microsoft Visual Studio.NET. If you download the control, provide your 

software developers with the download location, as well as the DynamicHelp serial number you were provided with. If 

you would like to see this control in action, check out the Dynamic Help pane of Doc-To-Help. 

 

A few notes about the DynamicHelp control 

Please note: If you are not the software developer who will be implementing the DynamicHelp control, please pass this 

information along to software development.  

 The C1DynamicHelp control can be only be used in the Microsoft Visual Studio (version 2005 or greater) 

development environment. (Software developers must have Visual Studio installed to use the control, but end 

users of the application developed will not.)  

 The entire ComponentOne Studio for WinForms suite will be installed, however, the serial number you 

received is for the DynamicHelp control only.  

 At the end of the install for Studio for WinForms, the installer will prompt you for your serial number.  Do not 

enter your serial number at this time, since it is asking for a serial number for the entire studio and you only 

have a serial number for DynamicHelp.  

 To activate Dynamic Help, you must activate through Visual Studio following the steps below: 

1. Start a new WinForms project.  

2. Go to the Toolbox.  

3. Select Dynamic Help and add it to the form.  

4. Right-click on the control and choose About.  

5. In the About box, click the Activate button.  

6. Enter the Dynamic Help serial number to activate. 
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Using Anti-virus Software with Doc-To-Help 
Note that some anti-virus software can limit the functionality of a range of software applications, including Doc-To-

Help.  

You should turn off your anti-virus software during installation, but please note that after Doc-To-Help is installed anti-

virus software may: 

 Interfere with the integration between Doc-To-Help and Microsoft® Word. 

 Limit or prohibit the use of scripting technology.  

If your anti-virus software alerts you with a warning while using Doc-To-Help, it may be necessary to modify the 

properties of your anti-virus software. 

For known issues relating to anti-virus software, contact Technical Support. See Troubleshooting on page 7 for details.  

Activating Doc-To-Help 
Activation is used by ComponentOne to verify the authenticity of the product key used to license the software and also to 

ensure that keys are only used to license an approved number of machines. The activation process does not collect any 

customer-specific information and protects the end user’s privacy completely.  

 

To activate Doc-To-Help 
You can activate Doc-To-Help after installation using the Doc-To-Help Activation Wizard, which will open 

automatically. 

 

 
 

In the Doc-To-Help Activation Wizard, choose the Enter your Serial Number radio button and click Next. Enter your 

serial number in the field provided and click Next to activate. 

 

To activate Doc-To-Help in Windows 7 or Vista, you must be logged in as an administrator. To log in as an 

administrator, right-click on any Doc-To-Help shortcut (from the Start menu or on your desktop) and choose Run as 

administrator from the menu. Doc-To-Help will open.  

 

You can also activate by phone, e-mail, or online.  All three processes are described here: 

https://c1verification.componentone.com/webfiles/. 

 

https://c1verification.componentone.com/webfiles/
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Deactivating Doc-To-Help 
If you need to move your copy of Doc-To-Help from the computer it is currently installed on to another one, you must 

deactivate the license before uninstalling.  Please note that once you have deactivated Doc-To-Help, it will not be 

useable. It will resume working once the license is installed on another computer and activated. 

For more information on activating/deactivating Doc-To-Help, see the Activation Overview web page. 

  

To deactivate Doc-To-Help 

Choose the File tab > Tools > Deactivate. 

Using Live Update 
Live Update is a utility that automatically checks for software updates every time you open Doc-To-Help. 

If a new version is available, the ComponentOne Doc-To-Help Live Update dialog box will open. The update number 

and new feature list will be displayed. Click the Download button to download the update. 

 

To disable Live Update 

1. Choose the File tab  > Tools > Options. The Options dialog box will open. 

2. Click the Live Update tab. 

3. Select the Do not check for updates automatically radio button. 

4. Click OK. 

 
To check for updates manually 

Choose the File tab > Tools > Check for Updates. 

 

http://c1verification.componentone.com/webfiles/default.aspx
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Troubleshooting 

 

 “Can’t install VC++ redistributable.”  
 
Issue:  

Under rare circumstances, Doc-To-Help may encounter a problem installing VC++ redistributables. If this happens, Doc-

To-Help will display a message that includes the link that you can use to install these redistributables manually. Click the 

link and download. 

 

http://www.microsoft.com/downloads/details.aspx?familyid=A5C84275-3B97-4AB7-A40D-

3802B2AF5FC2&displaylang=en  

 

If this does not solve the problem: 

 

If installing the redistributables does not solve the problem, please send your install log and your operating system 

information to the ComponentOne Support Team at the following address:  

 support.d2h@componentone.com 

The install log is located in the Temp folder of your machine. This is usually 

C:\\Users\<username>\AppData\Local\Temp. The file will be named: <setupfilename>.log   

http://www.microsoft.com/downloads/details.aspx?familyid=A5C84275-3B97-4AB7-A40D-3802B2AF5FC2&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=A5C84275-3B97-4AB7-A40D-3802B2AF5FC2&displaylang=en
mailto:support.d2h@componentone.com
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“Microsoft Word is Running” message 
 

After installation has started, if this message appears: 

 

 
 

1. Close Microsoft Word and Outlook. 

2. Go back to the error message and click Next. 

If the message appears again: 

1. Open the Task Manager (Ctrl-Alt-Delete) and select the Processes tab, not the Applications tab.  Close any 

instances of WINWORD.EXE and OUTLOOK.EXE. 
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2. Go back to the error message and click Next. 

 

Errors 1720 and 2738 
 

Error 1720: “There is a problem with this Windows Installer package. A script required for this install to 

complete could not be run.”  

Error 2738: “Could not access VBScript run time for custom action.” 

 

Both errors could be caused by the following: occasionally, system problems can erroneously unregister one of the 

essential Windows components: Windows Script Host. 

 
Solution 

You need to re-register vbscript.dll. To do so, execute the following command (you may want to consult your system 

administrator before doing so): 

Regsvr32.exe C:\windows\system32\vbscript.dll 
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Other Resources 
 

You may find the following generic Microsoft knowledgebase articles useful when troubleshooting: 

 

 http://support.microsoft.com/kb/555175 

 http://support.microsoft.com/kb/290301 

 

 
Contact Technical Support 

You can contact Technical Support with installation issues via email at supportd2h@componentone.com. 

The Technical Support phone number is 412-681-4738 and is available 9 am – 5 pm EST. 

 

Join the Forum 

Doc-To-Help: http://our.componentone.com/groups/doc-to-help/doc-to-help-24303/forum/  

General Help Authoring: http://our.componentone.com/groups/doc-to-help/general-help-authoring/forum/ 

http://helpcentral.componentone.com/CS/help_authoring_2/f/41.aspx 

 

Read the Blog 

http://our.componentone.com/topics/d2h/  

http://support.microsoft.com/kb/555175
http://support.microsoft.com/kb/290301
mailto:supportd2h@componentone.com
http://our.componentone.com/groups/doc-to-help/doc-to-help-24303/forum/
http://our.componentone.com/groups/doc-to-help/general-help-authoring/forum/
http://helpcentral.componentone.com/CS/help_authoring_2/f/41.aspx
http://our.componentone.com/topics/d2h/
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File Locations 

 

When you install Doc-To-Help, the software itself, Doc-To-Help Projects, Templates, Cascading File Sheets, and 

Themes will be installed by default, in the following locations. 

 
Doc-To-Help Software: 

\\Program Files\ComponentOne\DocToHelp (on 64-bit machines: \\Program Files (x86)\...) 

 

Doc-To-Help Projects: 

\\My Documents\My Doc-To-Help Projects (this can be changed in the Options dialog box, on the Files window (File 

tab > Doc-To-Help Options button) 

 

Word Templates: 

Templates are stored in Windows® 7 and Vista at: 

 C:\Users\ (user name)\AppData\Roaming\Microsoft\Templates 

 Windows® XP at C:\Documents and Settings\(user name)\Application Data\Microsoft\Templates. 

The Application Data or App Data folder is a hidden folder. To show hidden folders, open the Folder Options dialog 

box in your operating system (Control Panel > Folder Options). Click the View tab, under Advanced Settings > Files 

and folders > Hidden files and folders, select the Show hidden files and folders radio button. Click OK. 

You can change the default locations of Word Templates in Word using the Options dialog box (Word 2000/2002/2003) 

or Word Options (Word 2007+) 

 

Backups: If you upgrade Doc-To-Help, the latest 10 backups of your templates will be stored in a subfolder named 

“Backup” of the  \Templates folder  listed above. 

A note on changing your version of Microsoft Word: If you are a Word 2000/2002/2003 user, and you upgrade to 

Word 2007/2010 (or vice versa) without reinstalling Doc-To-Help, you will have a problem with your Templates, 

because the Templates for 2007/2010 are incompatible with 2000/2002/2003 Templates. The templates for each are 

stored here: 

Word 2000/2002/2003: \\Program Files\ComponentOne\DocToHelp\Templates\User  

Word 2007/2010: \\Program Files\ComponentOne\DocToHelp\Templates\User\Word2007 (on 64-bit machines: 

\\Program Files (x86)\...) 

Copy the templates from the appropriate folder and drop them in the correct \Templates folder for your operating system 

(listed above). 
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Add-Ins for Word: 

Doc-To-Help add-ins for Word (C1D2HAuthor.dot and C1D2HEngine.dot) are stored in the Word Startup directory, 

usually found at: C:\Users\ (user name)\AppData\Roaming\Microsoft\Word\Startup (but can be changed in Word 

Options.) 

 

Cascading Style Sheets: 

\\Program Files\ComponentOne\DocToHelp\DefaultCSSFiles. (on 64-bit machines: \\Program Files (x86)\...) 

 

Themes: 

\\My Doc-To-Help Projects\Doc-To-Help\Themes. They are stored in individual folders based on Target (output type). 
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